GPIO Eingänge (Befehle) werden nicht ausgeführt

DIE Community für die externe Anbindung von Robonect® in bestehende Systeme.
Grundkenntnisse in bereits beim Anwender vorhandenen Systemen werden vorausgesetzt.
Für externe Lösungen ist kein Support möglich. Anwender helfen Anwendern! Mach mit!
(Robonect® Hx und IO)
Antworten
Pollmi
Beiträge: 15
Registriert: Di 13. Mär 2018, 11:41
Mäher: Husqvarna Automower 310
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2017
Robonect-Modul: Robonect Hx (Rev.1)
Robonect Firmware: V1.1b

GPIO Eingänge (Befehle) werden nicht ausgeführt

Beitrag von Pollmi » Sa 13. Apr 2019, 18:52

Hallo zusammen,

ich habe in meinem Automower 310 das HX-Modul im Einsatz und möchte über meine Hausautomation (Rademacher Homepilot) meinen Robbi steuern.
Dazu habe ich die beiden OUT1/2 für Statusmeldungen verwendet (Öffnen/Schließen der Garage). Funktionier!
Die beiden GPIO1/2 für Befehle an den Robbi. Funktionier nur im Web-Interface, hier ändert sich auch der Status (An/Aus).
Aber die Befehle, z.B. Fahrt, Parkposition oder Such/Heimweg... werden nicht vom Robbi ausgeführt!?

Wenn ich über das Web-Interface (Steuerung) "Home" drücke, dann fährt er auch nach Haus.

Also alles funktionier, nur die GPIO-Eingänge haben keine Auswirkung.

Grüße Pollmi

Admin
Administrator
Beiträge: 2518
Registriert: Di 19. Jan 2016, 18:34
Wohnort: Kiel
Mäher: Gardena SILENO City 500
Firmware des Mähers (MSW): MSW 11.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: stets die Allerneuste :-)
Kontaktdaten:

Re: GPIO Eingänge (Befehle) werden nicht ausgeführt

Beitrag von Admin » So 14. Apr 2019, 10:17

Moin,
der Modus bezieht sich nur auf die Funktion als Ausgang.

Das Robonect Modul ist ja im Mäher eingebaut. Hast du an Robonect noch einen weiteren Funksender angebaut?!

Verstehe grad die Funktion nicht ganz.


Gesendet von iPhone mit Tapatalk
Werbefläche zu vermieten. :lol:

Pollmi
Beiträge: 15
Registriert: Di 13. Mär 2018, 11:41
Mäher: Husqvarna Automower 310
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2017
Robonect-Modul: Robonect Hx (Rev.1)
Robonect Firmware: V1.1b

Re: GPIO Eingänge (Befehle) werden nicht ausgeführt

Beitrag von Pollmi » So 14. Apr 2019, 20:53

Hallo,

ich habe an das Robonect Modul einen Funkaktor von Rademacher gebaut um ihn bei Regen nach Hause zu schicken. Und einen Funksensor um Informationen für die Torsteuerung zu bekommen. Hier für hab ich ich eine kleine Schnittstellenplatine gebastelt.
Es sollte doch eigentlich nur eine Software Geschichte sein um die Eingänge nutzbar zu machen?

Einen schönen Abend noch.

Admin
Administrator
Beiträge: 2518
Registriert: Di 19. Jan 2016, 18:34
Wohnort: Kiel
Mäher: Gardena SILENO City 500
Firmware des Mähers (MSW): MSW 11.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: stets die Allerneuste :-)
Kontaktdaten:

Re: GPIO Eingänge (Befehle) werden nicht ausgeführt

Beitrag von Admin » So 14. Apr 2019, 22:50

An sich ist es nur eine Softwaresache. Aber irgendwie macht es keinen Sinn, da es „doppelgemoppelt“ ist.
Die Informationen und Möglichkeiten sind ja bereits über die Robonect API verfügbar. Ich kenne jetzt die Rademacher Anlage nicht, aber kann man nicht lieber diese mir der API von Robonect verheiraten?!
Die extra Hardware im Mäher sehe ich als überflüssig.


Gesendet von iPhone mit Tapatalk
Werbefläche zu vermieten. :lol:

Pollmi
Beiträge: 15
Registriert: Di 13. Mär 2018, 11:41
Mäher: Husqvarna Automower 310
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2017
Robonect-Modul: Robonect Hx (Rev.1)
Robonect Firmware: V1.1b

Re: GPIO Eingänge (Befehle) werden nicht ausgeführt

Beitrag von Pollmi » Mo 15. Apr 2019, 14:52

Doppelt heißt aber nicht schlechter! Bei einem Automatikgetriebe kann man auch noch von Hand Schalten.

Der Rademacher Homepilot kann API, aber dann brauche ich einen Access point für den Garten, einen "Mini-Server" und viel Zeit mich in diese Thema einzuarbeiten.

Mit der extra Hardware im Mäher kann die Hausautomation ihr Potenzial voll ausschöpfen. Hier ist nach dem Einrichten nur eine direkte Verbindung zwischen Aktor (Garagentor) und Sensor (Robonect) nötig.

...und ein Eingang der nicht als Eingang verwendet werden kann :?: :?: :?:

Bitte, bitte, bitte bei der nächsten Firmware berücksichtigen.

Admin
Administrator
Beiträge: 2518
Registriert: Di 19. Jan 2016, 18:34
Wohnort: Kiel
Mäher: Gardena SILENO City 500
Firmware des Mähers (MSW): MSW 11.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: stets die Allerneuste :-)
Kontaktdaten:

Re: GPIO Eingänge (Befehle) werden nicht ausgeführt

Beitrag von Admin » Mo 15. Apr 2019, 16:16

Welche Funktion benötigst du genau? Ein GPIO der ihn nach Hause schickt (also Modus auf Home ändert), und ein GPIO der zurück auf Auto schaltet?!
Werbefläche zu vermieten. :lol:

Pollmi
Beiträge: 15
Registriert: Di 13. Mär 2018, 11:41
Mäher: Husqvarna Automower 310
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2017
Robonect-Modul: Robonect Hx (Rev.1)
Robonect Firmware: V1.1b

Re: GPIO Eingänge (Befehle) werden nicht ausgeführt

Beitrag von Pollmi » Mo 15. Apr 2019, 17:23

Genau, das sind genau die Funktionen die ich brauche.

Antworten

Zurück zu „Einbindung in Hausautomatisierung“