Auf diesem Gerät eingeloggt bleiben

Einbindung von Robonect Hx und IO in Deine bereits bestehende MQTT-Infrastruktur
Antworten
mikeyboy
Beiträge: 4
Registriert: Do 8. Jun 2017, 12:43
Mäher: Gardena smart SILENO+
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2017
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: 1.0 beta 7a

Auf diesem Gerät eingeloggt bleiben

Beitrag von mikeyboy » Di 26. Mär 2019, 07:51

Ich habe während meinen MQTT Tests unter Sicherheit Benutzer die Option "Auf diesem Gerät eingeloggt bleiben" aktiviert. Nach Abschluss dieser Test habe ich diese Option wieder deaktiviert. Seither habe ich den Eindruck dass die Option immer noch aktive ist. Im besten Fall werde ich bein Zugriff mit einem neuen Device (Smartphone oder Notebook) zur einmaligen Eingabe des Benutzernamens und Password aufgefordert, danach nie mehr. Weiter ist mir aufgefallen, dass nach einer gewissen Zeit kein Zugriff mehr möglich ist auf das Webinterface. Dies hat dann auch Auswirkungen auf die MQTT Verbindung, die dann im Viertelstunden Modus Offline Online geht. Es ist durchaus möglich das die mit der maximalen Anzahl der gleichzeitigen Zugriffe zusammen hängt. Da für mich nicht klar ist wann ein Smartphone seine Verbindung schliesst. Leider kann ich dies nicht überprüfen, da der Entwicklermodus nicht mehr verfügbar ist.
Schon mal Danke für Eure Unterstützung und Gruss
Mike

Benutzeravatar
shadowkiller
Beiträge: 1985
Registriert: Do 11. Jan 2018, 08:42
Wohnort: Würzburg
Mäher: Husqvarna Automower 315
Firmware des Mähers (MSW): MSW 10.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: V1.1b

Re: Auf diesem Gerät eingeloggt bleiben

Beitrag von shadowkiller » Di 26. Mär 2019, 19:40

Das sind ja gleich zwei Fragen auf einmal :D Ich versuche mal zu ordnen:
mikeyboy hat geschrieben:
Di 26. Mär 2019, 07:51
Ich habe während meinen MQTT Tests unter Sicherheit Benutzer die Option "Auf diesem Gerät eingeloggt bleiben" aktiviert. Nach Abschluss dieser Test habe ich diese Option wieder deaktiviert. Seither habe ich den Eindruck dass die Option immer noch aktive ist. Im besten Fall werde ich bein Zugriff mit einem neuen Device (Smartphone oder Notebook) zur einmaligen Eingabe des Benutzernamens und Password aufgefordert, danach nie mehr.
Wahrscheinlich musst Du auf dem entsprechenden Gerät/Browser zusätzlich das Cookie löschen, wenn Du den automatischen Login nicht wünschst. Wie ist es denn beim selben Gerät/Browser hier im Forum, wenn Du das Häkchen nach dem manuellen Logout und Re-Login mit Username/Passwort nicht setzt, den Browser komplett schliesst und dann nochmal ins Forum gehst? Dasselbe Verhalten?
Weiter ist mir aufgefallen, dass nach einer gewissen Zeit kein Zugriff mehr möglich ist auf das Webinterface.
...
Wie hast Du die Verbindung hergestellt? Heimnetz oder Robonect-AP? welche IP-Adressen hast Du jeweils vergeben, falls beide gleichzeitig aktiv sind?

Lektüre-Tipp: lies mal diesen Thread zu dem Thema aus der Beta5. Er ist recht lang und leider wirst Du alles lesen müssen, da die letzten Posts Dir nicht helfen werden. Darin findest Du ein paar Tipps zum Durchchecken der Dinge, die für Dein Problem verantwortlich sein könnten, u.a. auch MQTT. Vielleicht findest Du ja den entscheidenden Hinweis, oder auch im MQTT-Forum hier.

btw, welche Beta-Firmware (z.B. V1.0 Beta 7a = neuste) hast Du denn auf Robonect installiert? Dein Profil spricht von der 1.0, welche noch nicht released wurde.
WLAN oder Robonect funktioniert nicht? Erstmal die Tipps lesen!
--
Kompendium für Mähroboter: Download ERFAdoc (ca. 4,3 MB, 232 Seiten-PDF) von Fidatex
--
Es ist schon alles gesagt, nur noch nicht von allen. (Karl Valentin)

mikeyboy
Beiträge: 4
Registriert: Do 8. Jun 2017, 12:43
Mäher: Gardena smart SILENO+
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2017
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: 1.0 beta 7a

Re: Auf diesem Gerät eingeloggt bleiben

Beitrag von mikeyboy » Do 4. Apr 2019, 14:13

Danke Shadowkiller für Deine ausführliche Antwort.
in dem von Dir erwähnten Thred finde ich mich wieder. Ich vermute wie Du, dass das Problem von den maximalen Verbindungen her kommt. Aus meiner Sicht ist es auch gut möglich das die Ursache MQTT ist.
Da bei mir Robonect nur sendet müsste es auch die Verbindungen schliessen, bzw wenn zuviele Events gleichzeitig auftreten wird für jedes ein Session eröffnet oder öffnet Robonect eine Session und hält die offen? Was passiert mit dem MQTT Listener / Sender wenn der Broker nicht mehr verfügbar ist?
Ich bedauere es sehr, dass dieser Entwickler Mode nicht mehr verfügbar ist, weniger die fehlenden Konfiguration als die Monitoring Möglichkeiten.

Antworten

Zurück zu „MQTT-Nutzer“