[NICHT UMSETZBAR] Ladestation LED im Webinterface anzeigen

Leider gibt es das auch. Hier erfährst Du aber auch warum.
Bitte keinen neuen Wunsch formulieren, wenn Du Deinen hier findest! Schreibe gerne einen weiteren Beitrag, wenn der Wunsch aus Deiner Sicht dennoch erfüllbar ist und Deinen fundierten Lösungsvorschlag dazu.
Mal sehen, was der Entwickler dann dazu sagt, vielleicht hast Du ja Glück?!
Benutzeravatar
SenfmitHonig
Beiträge: 220
Registriert: So 30. Okt 2016, 22:39
Wohnort: 943xx
Mäher: Husqvarna Automower 430X
Firmware des Mähers (MSW): MSW 6.xx.xx
Herstellungsjahr: 2016
Robonect-Modul: Robonect Hx (Rev.2)
Robonect Firmware: V1.1b

[NICHT UMSETZBAR] Ladestation LED im Webinterface anzeigen

Beitrag von SenfmitHonig » So 24. Jun 2018, 09:17

Servus,
da ich dazu noch nichts in den Feature-Requests gefunden habe … würde ich hier den Ansatz von Fidatex mal am Beispiel des 430X beschreiben.
Fidatex hat geschrieben:
So 17. Jun 2018, 14:12
Da kommt mir gar ein Feature request: Auf der Statusseite sollte bei Schleife an der Stelle wo bei Health OK steht, ein Kreis der die LS LED darstellt sein, der grün leuchtet oder blau blinkt oder blau steqady oder orange blink oder rot wie die LED in der LS.
LS-LED.png
Dieser LED-Status könnte auch in der Statusleiste der Web-Seite angezeigt werden, glaube aber nicht das es dort zur Robonect-CI vom Fabian passt. ;)

Benutzeravatar
Fidatex
Beiträge: 577
Registriert: Sa 30. Jan 2016, 20:04
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 3.xx.xx
Herstellungsjahr: 2012
Robonect Firmware: -1.0B5

Re: Ladestation LED im Webinterface anzeigen

Beitrag von Fidatex » So 24. Jun 2018, 12:30

Genauso hab eich mir das Vorgestellt! Vielen Dank

Bei Gardena käme noch oranges blinken dazu = Sk gestört.

Und die übersicht und CI würde ich lösen indem der Punkt neben dem "Parkt" Feld angezeigt wird. Somit sieht man es auch auf den ersten Blickt und man weiss der Mäher parkt hat aber einen Fehler im Kabelsystem. Wenn der Mäher dann rausfährt und stoppt stünden dann Fehler und zB blau blinken = man weiss gleich was los ist.

Da kommt mir eine weitere Idee: weiss der Mäher wenn er rumsteht im Parkt ob er in der LS ist oder nicht?
Und sonst könnte man den ableiten: Status Mäher = parkt und Stomverbrauch > 50mA = nicht in LS

Anzeigen:
Parkt in LS
Parkt im Rasen (ist gut zu wissen, weil hier der Akku leergesoffen wird)
Saphira = R40Li 2012,MSW3.02,GT, lenkbares, rostfreies Heckrad,Garage mit Emotionlight & Intruderschutz, FritzDect, HX V1.0B6a ERFAdoc: viewtopic.php?f=8&t=1015

Benutzeravatar
Fidatex
Beiträge: 577
Registriert: Sa 30. Jan 2016, 20:04
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 3.xx.xx
Herstellungsjahr: 2012
Robonect Firmware: -1.0B5

Re: Ladestation LED im Webinterface anzeigen

Beitrag von Fidatex » Mo 25. Jun 2018, 17:10

Für Saphira mit MSW 3 wäre dieser Request extrem dringend. Ich habe einen mal da mal nicht da 10kOhm "Unterbruch" im BkRe und der ist im Schleifen mneü nicht sichtbar., d.h. LS blinkt blau aber Qualität wird 100% angezeigt und F-Feld ist auch da. Das ist wahrscheinlich sogar logisch, da in der LS das F-Feld ja da ist und wohl auch sonst. Die LED leitet sich ja auch nicht aus den Feld Werten ab sondern aus dem Widerstand in den Schlaufen. Brächte mich zum nächsten Idee: Sind die Widerstände dem Mäher auch bekannt > dann Anzeigen auf sep Tab oder werden die nur HW mässig in der LS "gemessen" dann ist LED abschliessende Lösung? Als Schmanckerl mit Maushoover Erläuterung der aktuellen LED Farbe Bedeutung.
Dateianhänge
Saphira parkt im Rasen Anzeige LED.JPG
Saphira parkt im LS Anzeige LED grün.JPG
Saphira parkt im LS Anzeige LED grün.JPG (18.64 KiB) 1157 mal betrachtet
Saphira = R40Li 2012,MSW3.02,GT, lenkbares, rostfreies Heckrad,Garage mit Emotionlight & Intruderschutz, FritzDect, HX V1.0B6a ERFAdoc: viewtopic.php?f=8&t=1015

Wildshunter
Beiträge: 106
Registriert: Mo 17. Apr 2017, 14:23
Wohnort: Main Taunus Kreis
Mäher: Gardena smart SILENO
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2016
Robonect-Modul: Robonect Hx (Rev.3)
Robonect Firmware: 1.0 Beta 7a

Re: Ladestation LED im Webinterface anzeigen

Beitrag von Wildshunter » Mo 25. Jun 2018, 23:24

+1
--- Gardena Sileno Smart mit Gleitscheibe....

Benutzeravatar
Fidatex
Beiträge: 577
Registriert: Sa 30. Jan 2016, 20:04
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 3.xx.xx
Herstellungsjahr: 2012
Robonect Firmware: -1.0B5

Re: Ladestation LED im Webinterface anzeigen

Beitrag von Fidatex » Di 26. Jun 2018, 19:01

Aktuell steht Saphira im Rasen und meldet Schleifenfehler. LS blinkt blau. Die Schleifenwerte sind gemäss Screenshot. Ich weiss nicht wie ich aus der Schleifenwertanzeige eine Schlussfolgerung auf LED blau blinkt, gescheige denn überhaupt eine vernünftige Schlussfolgerung ziehen soll (ich muss zumindest im ERFAdok nachschauen), für den Enduser ist das eine rein akademische Anzeige ohne jeglichen Nutzen, solange die OK Werte nicht aufgeführt sind (Farbbalken, num Werte OK von bis )siehe andere Feature request)sowieso.

Die Schlufo dass LED blau blinkt werde ich da aber nie aus dem Chart rauskriegen.

Sicher, für die deren Installation grad super läuft ist die LED im RN eher unwichtig, aber a) es erwischt jeden, früher oder später und b) Hand aufs Herz wenn alles läuft wie programmiert ist RN genauso überflüssig. Eine wichtige Stärke (nebst den 40er zum 70er machen) von RN liegt im Fehlerfall und für die die nicht dauernd daheim sein können. Just my five cents.
Dateianhänge
Saphira Schleifenfehler blau blinkt, Schleifenwerte.JPG
Saphira = R40Li 2012,MSW3.02,GT, lenkbares, rostfreies Heckrad,Garage mit Emotionlight & Intruderschutz, FritzDect, HX V1.0B6a ERFAdoc: viewtopic.php?f=8&t=1015

Admin
Administrator
Beiträge: 2506
Registriert: Di 19. Jan 2016, 18:34
Wohnort: Kiel
Mäher: Gardena SILENO City 500
Firmware des Mähers (MSW): MSW 11.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: stets die Allerneuste :-)
Kontaktdaten:

Re: Ladestation LED im Webinterface anzeigen

Beitrag von Admin » Do 28. Jun 2018, 14:05

Technisch leider nicht umsetzbar. Der Husky weiß nichts von der LED in der Station.
Werbefläche zu vermieten. :lol:

Benutzeravatar
Fidatex
Beiträge: 577
Registriert: Sa 30. Jan 2016, 20:04
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 3.xx.xx
Herstellungsjahr: 2012
Robonect Firmware: -1.0B5

Re: [NICHT UMSETZBAR] Ladestation LED im Webinterface anzeigen

Beitrag von Fidatex » Sa 30. Jun 2018, 15:36

Das ist echt Sch..., die LED ist eine der wichtigsten Indikatoren, wenn der Mäher nicht fährt. Ob das im Smart System auch so ist?

Fakt ist, wenn es blau blinkt stellt der Mäher ab. Also muss die Info irgendwie doch im Mäher ankommen oder dort berechnet werden.

Eins habe ich aber in dem Fall noch nicht verstanden: Wenn der Mäher nicht weiss, was die LED anzeigt, warum stellt er dann ab bei blau blink? Woher nimmt er die Info?? Weil aus den Schleifenwerten (zumindest die die die mir angezeigt werden) kann er die IMHO nicht haben, siehe Post Saphira.
Saphira = R40Li 2012,MSW3.02,GT, lenkbares, rostfreies Heckrad,Garage mit Emotionlight & Intruderschutz, FritzDect, HX V1.0B6a ERFAdoc: viewtopic.php?f=8&t=1015

Benutzeravatar
shadowkiller
Beiträge: 1956
Registriert: Do 11. Jan 2018, 08:42
Wohnort: Würzburg
Mäher: Husqvarna Automower 315
Firmware des Mähers (MSW): MSW 10.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: V1.1b

[NICHT UMSETZBAR] Ladestation LED im Webinterface anzeigen

Beitrag von shadowkiller » Sa 30. Jun 2018, 18:52

Bei blauem Blinken ist das Signal im Begrenzungsdraht gestört, richtig? Also stoppt der Mäher, weil er kein suffizientes Signal aus dem Begrenzungsdraht bekommt, nicht weil die Station irgendwas funkt - falsch?

shadowkiller
WLAN oder Robonect funktioniert nicht? Erstmal die Tipps lesen!
--
Kompendium für Mähroboter: Download ERFAdoc (ca. 4,3 MB, 232 Seiten-PDF) von Fidatex
--
Es ist schon alles gesagt, nur noch nicht von allen. (Karl Valentin)

Benutzeravatar
Fidatex
Beiträge: 577
Registriert: Sa 30. Jan 2016, 20:04
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 3.xx.xx
Herstellungsjahr: 2012
Robonect Firmware: -1.0B5

Re: [NICHT UMSETZBAR] Ladestation LED im Webinterface anzeigen

Beitrag von Fidatex » Sa 30. Jun 2018, 23:22

Gestört kann man so nicht sagen (dazu wäre ein Störsender nötig), Geschwächt wäre wohl korrekt, die blinkerei basiert meines Wissens und reverse enigneering (siehe Widerstandstabell im ERFAdok) rein auf dme Kabelwiderstand. Man kann annehmen dass bei steigendem Widerstand der Feldstrom abnimmt und damit die Feldstärke. Die Frage ist jetzt natürlich wie die Zusammenhangskurve Widerswtand zu Feldstärke aus der Sicht von Husky aussieht und welche Schlüsse der Mäher aus welcher Feldstärke zieht. So gesehen, finde ich den Titel nicht umsetzbar etwas verfrüht!!

Den Knopf dne ich noch lösen muss ist, warum habe ich F Signal satt bei blau blink?

1. Sind die im RN angezeigten Werte definitiv korrekt?
2. evt bei mir Problem wegen MSW 3?

Falls obiges klar wäre, würde ich eine reverse Tabelle erstellen, woraus man dann die LED ableiten kann.
Dazu brauche ich aber das Ok von Fabian, sonst lohnt es nicht.
Saphira = R40Li 2012,MSW3.02,GT, lenkbares, rostfreies Heckrad,Garage mit Emotionlight & Intruderschutz, FritzDect, HX V1.0B6a ERFAdoc: viewtopic.php?f=8&t=1015

Benutzeravatar
shadowkiller
Beiträge: 1956
Registriert: Do 11. Jan 2018, 08:42
Wohnort: Würzburg
Mäher: Husqvarna Automower 315
Firmware des Mähers (MSW): MSW 10.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: V1.1b

Re: [NICHT UMSETZBAR] Ladestation LED im Webinterface anzeigen

Beitrag von shadowkiller » So 1. Jul 2018, 08:13

Also ich denke, Fabian hat Recht.

Fidatex. Du bist sehr genau. Das ist bei Technik auch sehr wichtig. Aber Du sagst, dass es nicht „gestört“ heißt, sondern „geschwächt“, schreibst in Deinem Umsetzungsvorschlag-Mockup aber ebenfalls „... Störung im Begrenzungskabel“.

Es geht mir aber nicht um diese Wortglauberei.

Fabian hat deshalb Recht, weil es wohl keine technische Möglichkeit gibt, den Zustand der LED direkt abzufragen.

Das, was Du vorschlägst, ist das Interpretieren von Messwerten, die durch die Mäherelektronik der verschiedenen Mähroboter mit ihren facettenreich FIrmwares ggf. mit anderen Toleranzen und Algorithmen interpretiert werden, als dies Robonect berücksichtigen könnte.

Wenn man es schaffen würde, dies alles in aufwändigen Versuchsreihen reverse zu engineeren, dann könnte es allenfalls gelingen, eine Vermutung auszusprechen, welchen Zustand die LED in der Ladestation vermutlich/mit hoher Wahrscheinlichkeit hat.

Damit - und damit sind wir wieder am Anfang meines Beitrags - würdest Du Dich als sehr genau arbeitender Techniker auch nicht zufrieden geben dürfen.

Mal abgesehen von der Schwierigkeit der Umsetzung. Kannst Du Dir den Supportaufwand vorstellen, wenn Robonect aufgrund der oben beschriebenen Ungenauigkeit einen anderen Zustsand anzeigt, als die LED der Ladestation?

Auch deshalb hat Fabian Recht: nicht umsetzbar, wenn nicht an einem Wert direkt ablesbar.
WLAN oder Robonect funktioniert nicht? Erstmal die Tipps lesen!
--
Kompendium für Mähroboter: Download ERFAdoc (ca. 4,3 MB, 232 Seiten-PDF) von Fidatex
--
Es ist schon alles gesagt, nur noch nicht von allen. (Karl Valentin)

Antworten

Zurück zu „Wünsche, die nicht erfüllbar sind“