Gira Homeserver

Der Gira HomeServer ist der Bordcomputer für das intelligente Gebäude. Er verbindet die Elektroinstallation des KNX Systems mit dem Computernetzwerk und dem Internet. Damit ermöglicht er die zentrale Steuerung intelligenter Gebäudetechnik über eine Vielzahl an Bediengeräten - und das unabhängig vom Aufenthaltsort.
skyacer
Beiträge: 13
Registriert: Sa 10. Jun 2017, 11:39
Wohnort: nähe Hamburg
Mäher: Gardena R70Li
Firmware des Mähers (MSW): MSW 6.xx.xx
Herstellungsjahr: 2016
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: 1.0beta1

Re: Gira Homeserver

Beitrag von skyacer » Do 29. Jun 2017, 19:27

Okay etwas weiter bin ich jetzt. Nehm ich Wlan, Duration und Battery raus dann sendet er den Status. Warum das mit den anderen Sachen nicht geht müsste mir jetzt mal einer sagen....

Grüße

skyacer
Beiträge: 13
Registriert: Sa 10. Jun 2017, 11:39
Wohnort: nähe Hamburg
Mäher: Gardena R70Li
Firmware des Mähers (MSW): MSW 6.xx.xx
Herstellungsjahr: 2016
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: 1.0beta1

Re: Gira Homeserver

Beitrag von skyacer » So 9. Jul 2017, 10:59

Okay der Fehler ist gefunden. Es waren zwei kleine Kurschlüsse auf dem Board. Deswegen gingen wohl einige Anfragen nicht. Nach Austausch läuft dies nun zuverlässig.

Grüße

viceversa
Beiträge: 15
Registriert: Mo 9. Okt 2017, 15:01
Mäher: Husqvarna Automower 305
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2013
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: 1.0

Re: Gira Homeserver

Beitrag von viceversa » Mo 9. Okt 2017, 15:21

Hallo,

leider bekomme ich die Verbindung zum Homeserver nicht zum Laufen. Ist ja eigentlich nicht schwer und auch ausreichend hier im Topic dokumentiert. Andere User hatten ja auch Probleme.

Wenn ich die entsprechenden Befehle am Browser meines PC´s absetze, funktioniert es einwandfrei. Auch wenn ich es über ein Testprogramm (Send http Tool) probiere, werden die Befehle abgesetzt und ausgeführt. Über den Homeserver ging es sporadisch auch schon, aber ohne das ich einen Zusammenhang finden konnte wann es funktioniert und wann nicht.

Ich habe nur die Idee das es daran liegen könnte, das die Steuerung vom Homeserver aus nicht funktioniert, solange ich über den PC im Robonect-Modul angemeldet bin. Kann das sein? Gibt es eine Möglichkeit sich testweise abzumelden? Bzw. wann erfolgt die Abmeldung automatisch?

Vielen Dank!

viceversa
Beiträge: 15
Registriert: Mo 9. Okt 2017, 15:01
Mäher: Husqvarna Automower 305
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2013
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: 1.0

Re: Gira Homeserver

Beitrag von viceversa » Mo 9. Okt 2017, 18:42

Nachtrag:

In der Debug-Seite des Homeservers werden die Webabfragen als erfolgreich angezeigt. Offensichtlich werden sie also korrekt gesendet, aber der Mäher reagiert nicht darauf. (z.B. Betriebsartenumschaltung)

...
HTTP/1.1 200 OK Content-Type: text/xml Server: FHDR Connection: close Cache-Control: no-cache Connection: Close [?xml version="1.0" encoding="UTF-8" ?][robonect][successful]true[/successful][/
(Gesamt: 0) (Work: 0) (Typ: Liste) (OK: 1)

viceversa
Beiträge: 15
Registriert: Mo 9. Okt 2017, 15:01
Mäher: Husqvarna Automower 305
Firmware des Mähers (MSW): MSW 5.xx.xx
Herstellungsjahr: 2013
Robonect-Modul: Robonect Hx (Rev.4)
Robonect Firmware: 1.0

Re: Gira Homeserver

Beitrag von viceversa » Mo 9. Okt 2017, 23:13

Das Problem ist geklärt. Ich habe festgestellt das die Befehle ankommen, jedoch mit Verzögerungen von mehreren Minuten. Deshalb auch die sporadische Funktion. Dies traf auch auf andere Abfragen im Homeserver zu.
Ursache waren Verzögerungen im Homeserver durch mehrere, nicht antwortende Webabfragen.

Skynet74
Beiträge: 10
Registriert: Sa 21. Apr 2018, 10:00
Wohnort: MD
Mäher: Husqvarna Automower 420
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2017
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: 1.0beta5

Re: Gira Homeserver

Beitrag von Skynet74 » Fr 27. Apr 2018, 09:08

Eine Frage an die Homeserver-Nutzer. Ich habe soweit alle Status usw. umgesetzt und auch die Logik soweit fertig.
Ich möchte, sicherlich wie viele KNX User, den Mäher komplett in Logik des HS mähen lassen, also in Abhängigkeit der Wetterstation, der Bewässerung und eines HS-Timers.

Jetzt lese ich hier in den FAQs:
Mein Automower mäht, obwohl ich alle Timer deaktiviert habe. Warum?
"It's not a bug, it's a feature". Wenn alle Timer deaktiviert sind, wird die Mähfunktion im Auto-Modus nicht mehr durch diesen blockiert. Wenn Sie ihren Mäher durch ihre Haussteuerung individiualisiert mähen lassen wollen, so ist der richtige Weg nicht alle Timer zu aktivieren / deaktiviern, sondern alle Timer grundsätzlich zu entfernen. Soll der Mäher dann mähen, so schalten Sie diesen in den Auto-Modus. Wenn er nicht mähen soll, in den Home-Modus.
Fragen:
  • Ich habe alle Timer auf "aus". Wie soll ich die "entfernen"?
Ich würde mich freuen, wenn mir jemand einen Erfahrungstipp geben würde.

VG
Nico
Husquarva 420 + Robonect HX + Gira KNX Homeserver

ufkel
Beiträge: 14
Registriert: So 31. Jul 2016, 11:05
Mäher: Husqvarna Automower 310
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2016
Robonect-Modul: Robonect Hx (Rev.0)
Robonect Firmware: 1.0 Beta 8c

Re: Gira Homeserver

Beitrag von ufkel » Fr 27. Apr 2018, 09:45

Skynet74 hat geschrieben:
Fr 27. Apr 2018, 09:08
Eine Frage an die Homeserver-Nutzer. Ich habe soweit alle Status usw. umgesetzt und auch die Logik soweit fertig.
Ich möchte, sicherlich wie viele KNX User, den Mäher komplett in Logik des HS mähen lassen, also in Abhängigkeit der Wetterstation, der Bewässerung und eines HS-Timers.

Fragen:
  • Ich habe alle Timer auf "aus". Wie soll ich die "entfernen"?
Für alle Timer: Haken entfernen in Checkbox "Timer verwenden" und bei allen Wochentagen.
Mit http://IP/xml?cmd=mode&mode=auto
Ja

Gruß, Udo

Skynet74
Beiträge: 10
Registriert: Sa 21. Apr 2018, 10:00
Wohnort: MD
Mäher: Husqvarna Automower 420
Firmware des Mähers (MSW): MSW 7.xx.xx
Herstellungsjahr: 2017
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: 1.0beta5

Re: Gira Homeserver

Beitrag von Skynet74 » Fr 27. Apr 2018, 10:05

Danke vielmals! Schönes WE
Husquarva 420 + Robonect HX + Gira KNX Homeserver

nattermt
Beiträge: 7
Registriert: So 22. Apr 2018, 14:25
Wohnort: Einselthum
Mäher: Husqvarna Automower 315
Firmware des Mähers (MSW): MSW 10.xx.xx
Herstellungsjahr: 2018
Robonect Firmware: V1.0 Beta 4

Re: Gira Homeserver

Beitrag von nattermt » Fr 4. Mai 2018, 21:38

Hallo Zusammen,

ich versuche mich auch gerade an der HS Web Abfrage. Aber leider bekomme ich gar nix zurück!

Im Browser funktionieren alle Befehle einwandfrei.

Hat Jemand eine Idee??

Danke und Gruß,
Thomas
Dateianhänge
Screenshot 2018-05-04 21.35.18.png
Screenshot 2018-05-04 21.35.18.png (131.77 KiB) 2941 mal betrachtet
Screenshot 2018-05-04 21.35.42.png
Screenshot 2018-05-04 21.35.42.png (16.6 KiB) 2941 mal betrachtet
Screenshot 2018-05-04 21.35.49.png
Screenshot 2018-05-04 21.35.49.png (19.79 KiB) 2941 mal betrachtet
Screenshot 2018-05-04 21.35.56.png
Screenshot 2018-05-04 21.35.56.png (18.89 KiB) 2941 mal betrachtet

nattermt
Beiträge: 7
Registriert: So 22. Apr 2018, 14:25
Wohnort: Einselthum
Mäher: Husqvarna Automower 315
Firmware des Mähers (MSW): MSW 10.xx.xx
Herstellungsjahr: 2018
Robonect Firmware: V1.0 Beta 4

Re: Gira Homeserver

Beitrag von nattermt » Fr 4. Mai 2018, 22:03

ok, Fehler gefunden!

Habe den "/" bei der URL vergessen!

Gruß
Thomas

Antworten

Zurück zu „Gira HomeServer“