[BESTÄTIGT] EMail Versand fehlerhaft

- alle Auffälligkeiten, die es zu klären gilt
- Verdacht, dass ein echter Bug vorliegt
Antworten
ckmde
Beiträge: 3
Registriert: Fr 16. Nov 2018, 22:36
Mäher: Husqvarna Automower 308
Robonect Firmware: -

[BESTÄTIGT] EMail Versand fehlerhaft

Beitrag von ckmde » Fr 30. Nov 2018, 18:45

Hallo,

habe mir vor kurzem ein Robonect in meinen Husquarna 308 eingebaut und die 1.0 Beta 7 aufgespielt. Hat soweit sehr gut geklappt. Ich wollte dann den EMail Service einrichten. Das hat allerdings nicht bzw. erst nach langem suchen und dem Einbau einer Sonderlocke in meinem EMail Server geklappt. Ich betreibe meinen eigenen SMTP Server für meine Domain der auch im lokalen Netz auf Port 25 Mails annimmt. In der WebUI des Robonect habe ich den Benutzerdefinierten Server ausgewählt und als URL (was ein bisschen verwirrend ist) die IP Adresse des Servers eingetragen. Authentication gibt es lokal hier nicht und somit war da auch nichts drin. Absender ist eine lokale Adresse. Jeder Test damit ist fehlgeschlagen. Da so nicht zu erkennen war warum es fehlschlägt, habe ich mir die Tests auf dem Server mit tcpdump angesehen und festgestellt, dass das Modul Fehler im SMTP Protokoll macht. Nach dem Connect auf Port 25 meldet sich der Server mit der 220 und seiner Begrüßung und der Robonect sendet dann ein EHLO foobar.example.net (naja foobar.example.net ist zwar falsch, aber erstmal egal)
Als Antwort bekommt er von meinm SMTP Server was er für Optionen hat und da die Verbindung nicht verschlüsselt ist darf er kein AUTH machen. Bräuchte er aber auch nicht, da lokale Gerät alle senden dürfen.
250-mail.vienenbox.de Hello foobar.example.net [192.168.0.43]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-STARTTLS
250-SMTPUTF8
250 HELP

Jetzt sendet der Robonect trotzdem ein AUTH LOGIN was natürlich nicht akzeptiert wird und die Verbindung wird beendet.
Der Robonect darf kein AUTH LOGIN senden, wenn der Server das beim EHLO nicht als Option anbietet. Generell sollte der Robonect nicht versuchen eine AUTH zu machen, wenn kein Benutzername und Passwort in der WebUI eingetragen sind. Auch ein AUTH LOGIN scheint eher ungwöhnlich, kannte bisher nur AUTH PLAIN. Aber das ist egal. Ich habe meinem Exim jetzt erstmal einen AUTH LOGIN ohne TLS speziell für die IP-Adresse des Robnect eingerichtet. Aber ich halte es für einen BUG, dass das Modul überhaupt den AUTH Login versucht ohne das Authentication Daten eingetragen sind bzw. ohne das der Server diese Daten anfordert bzw. AUTH überhaupt zulässt.

Gruß
Carsten

Benutzeravatar
shadowkiller
Beiträge: 1018
Registriert: Do 11. Jan 2018, 08:42
Wohnort: Würzburg
Mäher: Husqvarna Automower 315
Firmware des Mähers (MSW): MSW 10.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: V1.0 Beta 7a

EMail Versand fehlerhaft

Beitrag von shadowkiller » Fr 30. Nov 2018, 21:40

Hi!
ckmde hat geschrieben: URL (was ein bisschen verwirrend ist)
Was ist an „smtp.mailservername.de“ verwirrend?
ckmde hat geschrieben:Jeder Test damit ist fehlgeschlagen.
auch wenn Du versucht hast mit Deinem E-Mail-Programm lokal dasselbe zu machen?

Geht es, wenn Du den Standardserver verwendest?
ckmde hat geschrieben:Da so nicht zu erkennen war warum es fehlschlägt, habe ich mir die Tests auf dem Server mit tcpdump angesehen und festgestellt, dass das Modul Fehler im SMTP Protokoll macht. Nach dem Connect auf Port 25 meldet sich der Server mit der 220 und seiner Begrüßung und der Robonect sendet dann ein EHLO foobar.example.net (naja foobar.example.net ist zwar falsch, aber erstmal egal)
Als Antwort bekommt er von meinm SMTP Server was er für Optionen hat und da die Verbindung nicht verschlüsselt ist darf er kein AUTH machen. Bräuchte er aber auch nicht, da lokale Gerät alle senden dürfen.
250-mail.vienenbox.de Hello foobar.example.net [192.168.0.43]
250-SIZE 52428800
250-8BITMIME
250-PIPELINING
250-STARTTLS
250-SMTPUTF8
250 HELP

Jetzt sendet der Robonect trotzdem ein AUTH LOGIN was natürlich nicht akzeptiert wird und die Verbindung wird beendet.
Der Robonect darf kein AUTH LOGIN senden, wenn der Server das beim EHLO nicht als Option anbietet. Generell sollte der Robonect nicht versuchen eine AUTH zu machen, wenn kein Benutzername und Passwort in der WebUI eingetragen sind. Auch ein AUTH LOGIN scheint eher ungwöhnlich, kannte bisher nur AUTH PLAIN. Aber das ist egal. Ich habe meinem Exim jetzt erstmal einen AUTH LOGIN ohne TLS speziell für die IP-Adresse des Robnect eingerichtet. Aber ich halte es für einen BUG, dass das Modul überhaupt den AUTH Login versucht ohne das Authentication Daten eingetragen sind bzw. ohne das der Server diese Daten anfordert bzw. AUTH überhaupt zulässt.
Schreibe bitte Fabian (Admin) eine PN und mache ihn damit bitte auf diesen Thread aufmerksam. Danke!
WLAN oder Robonect funktioniert nicht? Erstmal die Tipps lesen!
--
Kompendium für Mähroboter: Download ERFAdoc (DL-Link) von Fidatex

viahack
Beiträge: 199
Registriert: Di 26. Jul 2016, 16:08
Wohnort: Schönster Teil Deutschlands
Mäher: Gardena R40Li
Firmware des Mähers (MSW): MSW 2.xx.xx
Herstellungsjahr: 2011
Robonect-Modul: Robonect H30x (Rev.0)
Robonect Firmware: 1.0 beta 5

Re: EMail Versand fehlerhaft

Beitrag von viahack » Fr 30. Nov 2018, 22:33

Hallo Carsten,

habe bei einer ähnlichen Analyse des Netzwerkverkehrs die gleichen Merkwürdigkeiten gesehen.

Bei mir geht die Namensauflösung unter "SMTP-Server URL:".

Die leicht unhöfliche Art mit "EHLO foobar.example.net" zu Antworten kann ich bestätigen.

Gruß

Viahack
Automower: R40Li MSW-Version:2.01.00 MSW-Datum: 2011-09-05 17:32:18 SUB-Version: 2.00.00
Bootloader: V0.4 Kompiliert: 22.10.2016 01:12
W-LAN: AT-Version:V0.51.0 SDK-Version:V1.5.0
Hardware Seriennummer: 05DB0030-39394848-43115243

ckmde
Beiträge: 3
Registriert: Fr 16. Nov 2018, 22:36
Mäher: Husqvarna Automower 308
Robonect Firmware: -

Re: EMail Versand fehlerhaft

Beitrag von ckmde » Fr 30. Nov 2018, 22:36

Hallo,
shadowkiller hat geschrieben:
Fr 30. Nov 2018, 21:40
Was ist an „smtp.mailservername.de“ verwirrend?
Das ist keine URL sondern einfach ein Hostname. Man kann im dem Feld auch direkt die IP-Adresse des Servers eingeben was ja auch üblich ist. Nur das URL hat mit verwirrt, habe ich an so einem Feld noch nicht als Beschriftung gesehen. Ich habe da natürlich die IP-Adresse eingetragen, nur da es nicht funktionierte hat es mich verwirrt und ich habe mich gefragt ob vielleicht doch etwas anderes gemeint war. Ich habe diverse Geräte hier die Mails versenden und da steht praktisch immer SMTP Server IP Address wenn sie keine Namensauflösung können oder SMTP Server Hostname. Aber das ist auch nicht so wichtig.
ckmde hat geschrieben:Jeder Test damit ist fehlgeschlagen.
shadowkiller hat geschrieben:
Fr 30. Nov 2018, 21:40
auch wenn Du versucht hast mit Deinem E-Mail-Programm lokal dasselbe zu machen?
Ich habe diverse Geräte hier die auch irgendwelche Statusmeldungen senden, die funktionieren. Meine Clients brauchen im lokalen Netzwerk keine Authentication. Wenn die Clients von außerhalb des lokalen Netzes kommen, dann nutzen sie SMTP AUTH aber können das nur wenn TLS verschlüsselt wird.
shadowkiller hat geschrieben:
Fr 30. Nov 2018, 21:40
Geht es, wenn Du den Standardserver verwendest?
Habe ich nicht getestet, da das Modul keinen Zugriff auf das Internet hat.
shadowkiller hat geschrieben:
Fr 30. Nov 2018, 21:40
Schreibe bitte Fabian (Admin) eine PN und mache ihn damit bitte auf diesen Thread aufmerksam. Danke!
Mache ich.

Gruß
Carsten

Admin
Administrator
Beiträge: 2162
Registriert: Di 19. Jan 2016, 18:34
Wohnort: Kiel
Mäher: Gardena SILENO City 500
Firmware des Mähers (MSW): MSW 11.xx.xx
Herstellungsjahr: 2017 (Modell 2018)
Robonect-Modul: Robonect Hx (Rev.5)
Robonect Firmware: stets die Allerneuste :-)
Kontaktdaten:

Re: [BESTÄTIGT] EMail Versand fehlerhaft

Beitrag von Admin » Di 4. Dez 2018, 13:47

Werde ich fixen. Ich werde in diesem Zusammenhang neben LOGIN auch PLAIN und CRAM-MD5 implementieren.
Werbefläche zu vermieten. :lol:

Antworten

Zurück zu „Bug?“